View unanswered posts | View active topics It is currently Thu Sep 21, 2017 3:16 am



Reply to topic  [ 79 posts ]  Go to page 1, 2, 3, 4  Next
 MSVCP100.dll and 0xc000007b errors 
Author Message


Joined: Thu Jul 01, 2010 5:47 pm
Posts: 60
Post MSVCP100.dll and 0xc000007b errors
I get those errors every tiem i try to run 1.10. MSVCP100.dll I added using run command and that was solved, now I get the other error every time I try to run the new version. Any help would be appreciated. :)


Sun Feb 20, 2011 3:33 am
Profile E-mail
User avatar


Joined: Tue Nov 23, 2010 5:26 am
Posts: 13
Location: Philippines
Post Re: MSVCP100.dll and 0xc000007b errors
You can download MSVCP100.dll here: .... :bg:

Edit by Trigger Happy: invalid link deleted.


Sun Feb 20, 2011 4:39 am
Profile E-mail YIM
User avatar


Joined: Thu Jun 03, 2010 10:31 am
Posts: 1776
Location: Brazil
Post Re: MSVCP100.dll and 0xc000007b errors
There's a link in the readme.
No need to create a topic for this.

_________________
Facebook / YouTube 1 / YouTube 2 / Twitter / Steam

PSN accounts: Thunderstrucker2 - Thunderstruker - ThunderGearhead


Sun Feb 20, 2011 5:54 am
Profile E-mail
User avatar


Joined: Sat May 15, 2010 6:42 pm
Posts: 97
Location: England
Post Re: MSVCP100.dll and 0xc000007b errors
Whenever I try to run Generally 1.1, I get the error "The procedure entry point_invalid_parameter_noinfo_noreturn could no be located in the dynamic link library MSVCR100.dll" come up. Why, and how can it be dealt with?


Sun Feb 20, 2011 12:00 pm
Profile E-mail
User avatar


Joined: Mon Mar 15, 2010 11:30 am
Posts: 187
Location: Włocławek, Poland
Post Re: MSVCP100.dll and 0xc000007b errors
You installed C++ libraries? Read readme.


Sun Feb 20, 2011 12:10 pm
Profile E-mail
User avatar

Global Moderator

Joined: Sun Dec 27, 2009 3:03 pm
Posts: 1186
Location: Poland
Post Re: MSVCP100.dll and 0xc000007b errors
You need to have runtimes from links in readme AND fresh install of 1.10. When I first downloaded the .dll's themselves and put them into GR folder, then installed runtimes it didn't work. So you need fresh install of GR 1.10.

_________________


[cpk] [tou] [ser] TTA 2012 | [cpk] [gtc] GT Pack | [cpk] [ral] WRC Cars: Cordoba, Impreza, SX4 | [cpk] [tou] Touring Cars (reuploaded)


Sun Feb 20, 2011 12:20 pm
Profile E-mail
User avatar


Joined: Sat May 15, 2010 6:42 pm
Posts: 97
Location: England
Post Re: MSVCP100.dll and 0xc000007b errors
Got it working. Thanks


Sun Feb 20, 2011 12:37 pm
Profile E-mail


Joined: Thu Jul 01, 2010 5:47 pm
Posts: 60
Post Re: MSVCP100.dll and 0xc000007b errors
I had read the readme and installed runtimes, tried fresh install and still get the error.

Win7
Turion X2 mobile
4 gb ram
radeon hd4570


Sun Feb 20, 2011 7:38 pm
Profile E-mail
User avatar

GeneRally Wizard

Joined: Sun Dec 27, 2009 3:46 pm
Posts: 176
Location: Germany
Post Re: MSVCP100.dll and 0xc000007b errors
maybe try the 32bit version if 64bit doesnt work for you.

Cu Crono

_________________
PlanetGeneRally - German GeneRally Community
Track Database: over 650 Tracks available!


Sun Feb 20, 2011 11:57 pm
Profile E-mail ICQ WWW
User avatar


Joined: Sat Feb 06, 2010 1:43 pm
Posts: 154
Location: Encantado - RS (Brazil)
Post MSVCR100.dll - ERROR, can't open GR1.10
Somebody know's what to make to fix this? I almost crying here... :weep:

I can't open GR or even Track Editor because of this problem...

_________________
Revenge is never full, it kills the soul and poisons. (By Seu Madruga)


Mon Feb 21, 2011 10:46 pm
Profile
User avatar


Joined: Mon Nov 15, 2010 4:50 pm
Posts: 1203
Location: Rio de Janeiro, Britannia
Post Re: MSVCR100.dll - ERROR, can't open GR1.10
Santana 2.0 wrote:
Somebody know's what to make to fix this? I almost crying here... :weep:

I can't open GR or even Track Editor because of this problem...

Sanatna, baixe o arquivo pedido no Leia-me
(download the file required on readme)


Mon Feb 21, 2011 10:53 pm
Profile E-mail
User avatar

Global Moderator

Joined: Sun Dec 27, 2009 3:03 pm
Posts: 1186
Location: Poland
Post Re: MSVCP100.dll and 0xc000007b errors
Post moved to this thread as their theme is the same.

My suggestion is the same:
Paw wrote:
You need to have runtimes from links in readme AND fresh install of 1.10. When I first downloaded the .dll's themselves and put them into GR folder, then installed runtimes it didn't work. So you need fresh install of GR 1.10.

_________________


[cpk] [tou] [ser] TTA 2012 | [cpk] [gtc] GT Pack | [cpk] [ral] WRC Cars: Cordoba, Impreza, SX4 | [cpk] [tou] Touring Cars (reuploaded)


Mon Feb 21, 2011 11:01 pm
Profile E-mail


Joined: Thu Jul 01, 2010 5:47 pm
Posts: 60
Post Re: MSVCP100.dll and 0xc000007b errors
Tried that, installed both runtimes, registered the .dll, downloaded and unzipped fresh copy of 1.10, no dice.


Tue Feb 22, 2011 2:35 am
Profile E-mail
User avatar


Joined: Mon Mar 15, 2010 11:30 am
Posts: 187
Location: Włocławek, Poland
Post Re: MSVCP100.dll and 0xc000007b errors
Don't install both runtimes! You need to install only one matching to your system's version.


Tue Feb 22, 2011 2:53 pm
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Sat Dec 26, 2009 9:54 pm
Posts: 7083
Location: CZE
Post Re: MSVCP100.dll and 0xc000007b errors
Very important is to have those dlls in machine just once. If you have any duplicates on it, delete them, it can help! :bg:

_________________

My GR Racing Stats; thanks to GWR!


Tue Feb 22, 2011 10:02 pm
Profile E-mail WWW
User avatar

GeneRally Trackmaster

Joined: Sat Mar 27, 2010 10:52 am
Posts: 101
Location: Brussels
Post Re: MSVCP100.dll and 0xc000007b errors
I followed all the instructions (installed the MS C++ pack, downloaded the .dll manually), but when I tried to register the .dll, I get an error from my machine. So I thought the .dll I downloaded (the one linked above) was faulty.

Did several restarts as well, reinstalled the .Net framework. If this hadn't been a new version of GR, I would have given up long ago.


What worked was installing the 32-bit/x86 runtime, even though I have a 64-bit system :-/

Phew.

_________________
// My old tracks (2003-2010) | My new tracks (2011-2012) //


Wed Feb 23, 2011 12:07 am
Profile E-mail
User avatar


Joined: Wed Feb 09, 2011 5:06 pm
Posts: 2
Location: City 17
Post Re: MSVCP100.dll and 0xc000007b errors
Well, I've read the readme, and I still can't play. When I try to open GR, it says

The procedure entry point
??1_NonReentrantPPLLockHolder@details!Concurrency@@QAE@XZ
could not be located in the dynamic link library MSVCR100.dll.

I mean, what the heck? The TrackEditor works just fine, but not the dang game... :vsad:

_________________
LFSFOREVER
Proud resident of North Ameristralia!


Wed Feb 23, 2011 3:25 am
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Thu Dec 31, 2009 7:26 pm
Posts: 263
Location: United Kingdom
Post Re: MSVCP100.dll and 0xc000007b errors
Sorry to hear that you guys are having problems - but if you are getting that error message, then the libraries have not installed successfully. As Nielske mentioned, 64-bit users may need to try the 32-bit version... GR is built for 32-bit, so this may be the issue some of you are having (if so, I'll be sure to update the readme in v1.10b, due on Monday).

We technically could statically link (i.e. include in the exe) the libraries, but Microsoft strongly advise against doing that, for security reasons - so it's not something we'll be doing. Rest assured, though: once you've got the libraries installed, GR requires no other dependencies (other than SDL.dll, which is included).

Additionally, as a point of clarification, GR does not use the .NET framework :)

_________________
GeneRally Developer
Website - Developer Blog
_________________________

Follow GR on Twitter, Facebook and Google+.


Wed Feb 23, 2011 9:47 am
Profile WWW


Joined: Wed May 26, 2010 6:21 pm
Posts: 15
Post Re: MSVCP100.dll and 0xc000007b errors
Don't mean to sound like a complete noob.

But do you extract the msvcp100.dll file into your GR directory?


Fri Feb 25, 2011 5:06 pm
Profile E-mail


Joined: Wed May 26, 2010 6:21 pm
Posts: 15
Post Re: MSVCP100.dll and 0xc000007b errors
Hang on, it works!


Fri Feb 25, 2011 5:22 pm
Profile E-mail
User avatar

GeneRally Wizard

Joined: Sat Jan 02, 2010 10:58 am
Posts: 138
Location: Out in the woods of Crystal River, Florida!
Post Re: MSVCP100.dll and 0xc000007b errors
squisheebender wrote:
Don't mean to sound like a complete noob. But do you extract the msvcp100.dll file into your GR directory?


1) Download -> http://download.microsoft.com/download/ ... st_x86.exe

2) Run vcredist_x86.exe .

Note that this is for the 32-bit versions of Windows. As James posted, even of you have a 64-bit version of Windows, GeneRally *might* just require the 32-bit version of the runtimes.

If not, the 64-bit download is here -> http://download.microsoft.com/download/ ... st_x64.exe .

_________________
Rich ¥Weeds¥ Nagel
www.richnagel.net
¥Weeds¥ GeneRally Stuff - ALL broken links FINALLY fixed!
¥Weeds¥ File Archives - Music, stuff, and more.


Fri Feb 25, 2011 5:24 pm
Profile E-mail ICQ YIM WWW
User avatar


Joined: Mon Feb 21, 2011 6:13 am
Posts: 6
Post I have the .dll files, but the game still won't run.
It gives me an error saying something about not being able to start correctly, with the usual error code displayed. I tried going by the instructions displayed in the topic I found via search, but it's not working. When I run it with the .dlls in my System32 folder, it says they can't be found. But when I put them in my GeneRally directory, it says the application was unable to start correctly. I'm working from Windows 7, by the way.

I did try reinstalling a fresh copy of GeneRally, but it still wouldn't work. Do I need to put in the DLLs in a certain order before or after installing?

_________________
Larcen Tyler
Some Eternal Champions just never die.


Tue Apr 19, 2011 10:12 pm
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Sat Dec 26, 2009 9:54 pm
Posts: 7083
Location: CZE
Post Re: I have the .dll files, but the game still won't run.
try to ''install'' whole the pack like recommends readme, not downloading single libraries

_________________

My GR Racing Stats; thanks to GWR!


Tue Apr 19, 2011 10:16 pm
Profile E-mail WWW
User avatar


Joined: Mon Feb 21, 2011 6:13 am
Posts: 6
Post Re: I have the .dll files, but the game still won't run.
Should I install the DLLs first and then do a fresh install of GeneRally, or vice versa?

_________________
Larcen Tyler
Some Eternal Champions just never die.


Tue Apr 19, 2011 11:16 pm
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Sat Dec 26, 2009 9:54 pm
Posts: 7083
Location: CZE
Post Re: I have the .dll files, but the game still won't run.
I meant download whole the 32 bit runtime file from Microsoft page and install it (and before delete the two dlls from your PC).

_________________

My GR Racing Stats; thanks to GWR!


Tue Apr 19, 2011 11:24 pm
Profile E-mail WWW
Display posts from previous:  Sort by  
Reply to topic   [ 79 posts ]  Go to page 1, 2, 3, 4  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.