GeneRally International Forum
http://forum.generally-racers.com/

AI's can not into pits
http://forum.generally-racers.com/viewtopic.php?f=10&t=5362
Page 1 of 1

Author:  stonek89 [ Fri May 03, 2019 4:30 pm ]
Post subject:  AI's can not into pits

Hello again, I recently started working on my next track. I'm pretty sure how to create both racing and pit AI lines. The issue is: AI first complete a lap, an then after turn1 start to pit. It's like AI don't detect pit line before last turn. I've raced on hundreds of tracks, and this is the first time I see something like this.

I'm attaching the track and a screenshot from a test drive with high fuel usage rate. As you can see - AI's head "straight" to the pits after turn 1.

Attachments:
Cinkead.zip [9.18 KiB]
Downloaded 10 times
shot0002.jpg
shot0002.jpg [ 86.66 KiB | Viewed 403 times ]

Author:  Gzehoo [ Fri May 03, 2019 9:13 pm ]
Post subject:  Re: AI's can not into pits

Hmm... it's interesting but it may be caused by... track length based on AI Line.

Check it out. In your file it's >1500m, in my file it's >1200m.

Tested it with random fuel consumption/tyre wear, also in 1.2c and 1.2d and it's still problem on your track :scratch:

Attachments:
Cinkead2.zip [8.89 KiB]
Downloaded 5 times

Author:  stonek89 [ Sat May 04, 2019 5:41 pm ]
Post subject:  Re: AI's can not into pits

Thanks for looking into it :bg: . I didn't change racing line, but I was recreating pit line until I managed to "fix" it. I don't know what exactly causes this behaviour, but it seems to be something about first pit waypoint.

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/