View unanswered posts | View active topics It is currently Tue Nov 21, 2017 12:39 am



Reply to topic  [ 40 posts ]  Go to page 1, 2  Next
 GeneRally v1.2 - BUG REPORTS 
Author Message
User avatar

GeneRally Trackmaster

Joined: Thu Dec 31, 2009 7:26 pm
Posts: 263
Location: United Kingdom
Post GeneRally v1.2 - BUG REPORTS
GeneRally 1.2 - Bug Reports

This thread is for bug reports only (no feature requests). Please follow the format and guidelines outlined below or your post will be deleted.

Please do not report bugs that were previously reported in the v1.10 Bug Reports thread unless they have been marked as 'FIXED' in version.txt

Markku or I will edit posts that we have read to update their status. We will add a quote box at the top with relevant information. Please do not remove it, as it will be used for us to keep track of the bugs you have reported :bg:

Status Messages
  • Fixed - this has been fixed already (but may or may not be in a public release).
  • Targeted for next version - we will aim to include this fix in the next release of any kind.
  • Targeted for a future version - we will aim to include this fix in a future, but not necessarily the next, version.
  • Under consideration - we are considering whether we can/will fix this issue (typically, these are not strictly bugs, but more 'problematic features').
  • Already reported - another user has already reported this issue (post content will be removed for ease-of-reference).
  • Cannot reproduce this issue - your reproduction steps don't work for us. This means we probably won't be able to fix the issue until we have more information.
  • Intended behaviour - this is not a bug but a deliberate feature.
  • Rejected - this will not be fixed for the foreseeable future (usually due to a game engine limitation).


Guidelines
  • You must give your system specifications (operating system version and hardware set-up).
  • You must give reproduction steps that work every time for you.
  • You must provide screenshots where appropriate.
  • You must write in clear and concise English.
  • If possible, you should test to see if you can observe the bug in v1.10c.


Format Example
Quote:
Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
The game crashes when I create an AI driver with 101 skill level.

Expected Behaviour
The game should not crash when creating AI drivers.

Reproduction
  1. Open the Drivers menu
  2. Select 'Create', enter a name and select 'computer' type and press 'OK'
  3. Set the driver skill to 101.
  4. Press OK

System Configuration
Operating System: Windows 7
Hardware: Intel Core 2 Duo 3.0 GHz, 2x2gb DDR2 PC3200 RAM, ATi Radeon HD 4850 512MB PCI-E, 500GB SATAII HDD, ASUS Xonar D2 Audio.


This format is important so that we can identify and fix bugs easily - but, obviously, we cannot guarantee to fix every bug!

Thanks for your co-operation :bg:

_________________
GeneRally Developer
Website - Developer Blog
_________________________

Follow GR on Twitter, Facebook and Google+.


Sun Jul 08, 2012 2:10 pm
Profile WWW
User avatar

GeneRally Carmaster

Joined: Sun Dec 27, 2009 10:59 am
Posts: 4125
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Rejected. This won't be fixed. It's a side effect of something else that's a hugely disproportionate in time vs. benefit.


Very minor issue this one, but it IS one.

Problem
Observed in v1.2? Yes
Observed in v1.10c? Sort of (taskbar icon works, program icon doesn't)
Observed in v1.05? No
There appears to be no GR icon displayed next to the program window in the task bar, but a generic "icon not found" one is shown instead. (and yes, I did create a new directory). The same happens at the top of the window itself

Expected Behaviour
The game should display the GeneRally logo icon correctly in both the task bar and program bar.

Reproduction
Run GR in windowed mode, you will see for yourself.


System Configuration
Operating System: Windows Vista Home Premium SP2
Hardware: Intel Core i3 2120 3.4 GHz, 2x2gb DDR3 RAM, NVidia GeForce 8600GTS 256MB PCI-E, 640GB+2x160GB HDDs (game on 640 GB HDD), ASUS Xonar DG


Sun Jul 08, 2012 3:34 pm
Profile
User avatar


Joined: Mon May 10, 2010 2:24 pm
Posts: 846
Location: Cardiff, Wales
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. We ninja-patched this one. If you have this issue, re-download v1.2 from the GR home-page. Many thanks to Martyn for testing this quick fix.


Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
Menu cut off at the bottom of TE.

Expected Behaviour
Menu should be visable.

Reproduction
1.Open Track Editor


Attachments:
teprob.jpg
teprob.jpg [ 62.4 KiB | Viewed 10579 times ]

_________________
Hannu, who art in Finland, Räbinä be thy name. Sim racers come, races are won, at Agari, as at Xupong. Give us this day our version 1.06, and forgive us all our impatience, as we race those who challenge against us. Lead us not into boredom, but deliver us from work. For thine is the GeneRally, and the AI, and the race cars. Amen!
Sun Jul 08, 2012 3:49 pm
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Tue Dec 29, 2009 6:37 pm
Posts: 4725
Location: NRW in Germany
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. This no longer occurs in v1.2b.


Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
The game crashes when I hit any of the new (blue) cones at Estio.

Expected Behaviour
The game should not crash when I hit these cones, they should instead fly away.

Reproduction

1. Select Estio as a track and Player as a driver (or anyone else who hits the road cones).
2. Enter the first corner (or anywhere else where there are blue cones at the track) on the inside.
3. The game will crash.

System Configuration
Operating System: Windows XP Home SP3
Hardware: Intel Core 2 Duo 3.0 GHz, 4gb RAM, Nvidia Geforce 9800GT, 500GB HDD
I tested it in windowed mode (640 * 480 px) and in fullscreen (1680 * 1050)

_________________
My e-mail-address:xyyverwaltung@googlemail.com
Last track: deRUkt89.-Z+ - Last car: Ford Falcon GTHO Phase III


Last edited by XYY on Sun Jul 08, 2012 9:55 pm, edited 1 time in total.



Sun Jul 08, 2012 9:30 pm
Profile
User avatar

GeneRally Trackmaster

Joined: Sun Jan 03, 2010 11:04 pm
Posts: 743
Location: Slovenia
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Intended behaviour. This is functioning as designed.

Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
Speed limiters are interchangable.

Expected Behaviour
Limiter 1 should only limit your speed and limiter 2 should only lift the limit.

Reproduction
1. Open one of TuomoH's new default tracks (in my case it was Ohful).
2. Drive through any of the limiters.
3. See your car being slowed down regardless of which limiter you crossed first, and sped up regardless of which limiter you crossed second.

_________________
Visit My GeneRally site!
Join the Joint Effort Tree (JET) project here!


Sun Jul 08, 2012 9:36 pm
Profile E-mail WWW
User avatar

GeneRally Trackmaster

Joined: Mon Dec 28, 2009 12:09 pm
Posts: 2314
Location: England
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Already reported. Reference.


Problem
Observed in v1.2? Yes
Observed in v1.10c? N/A
Observed in v1.05? N/A

I have loaded a WIP of a track made in 1.10c, and made changes using new objects in 1.2 track editor, including adding the moving cone. Upon saving the track and loading into a GR 1.2, when either I or an AI make contact with the movable roadcone in time trial or race mode, the game immediately crashes.

Error message simply says "Generally top-down racing game has crashed. Windows is looking for a solution to the problem..."

I tried again with a New track built in trackeditor 1.2, added the moving cone, game ran without issue. It only seems to affect previous build tracks with new objects.

Probably not an issue in the long run, but may be deemed an issue if people are updating old tracks with new content..

Expected Behaviour
Game should not crash

Reproduction
as above, use previous build track, add new cone, drive into it.

System Configuration
Operating System: Windows 7 Home Premium 64-bit OS.
Hardware: Intel Core i5 2.67GHz, 4gb RAM, NVidia GeForce 315M,

_________________
G-TRACKS
Joint Effort Track Project
2015 GRIF F1 Prediction Game
My GeneRally


Sun Jul 08, 2012 9:47 pm
Profile E-mail
User avatar


Joined: Tue Jun 29, 2010 4:07 pm
Posts: 232
Location: UK
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Rejected. User didn't remove v1.10c options.set before launching GR v1.2.


Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No

Fullscreen option, when clicking "off", it doesn't "toggle" to "on".

Expected Behaviour
It should toggle, letting me select between "On" and "Off".

Reproduction
> Options
> Advanced
> Click "off" next to the fullscreen option

System Configuration
Operating System: Windows 7
Hardware: AMD Athlon II X2 Processor M300 (2.0GHz, 1MB L2 Cache), 3GB RAM, ATi Radeon HD 4200 Graphics, Resolution of 1600x900.

EDIT: Tried and now working, thanks


Last edited by JWong on Mon Jul 09, 2012 12:54 pm, edited 1 time in total.



Sun Jul 08, 2012 11:03 pm
Profile
User avatar


Joined: Fri Nov 05, 2010 9:33 am
Posts: 432
Location: United Kingdom
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. This no longer occurs in v1.2b - many thanks for your help on this one.


Problem
Observed in v1.2? Yes
Observed in v1.10c? Yes
Observed in v1.10b? Yes
Observed in v1.10? Yes
Observed in v1.05? No
The game does not sort tracks, car(file)s nor drivers by alphabet.

Expected Behaviour
The game should sort tracks, car(file)s and drivers by alphabet.

Reproduction
Launch GeneRally and look under any drop down menu.

System Configuration
Operating System: Windows XP Home Edition Service Pack 3
Hardware: Intel Core 2 Quad CPU 2.4 GHz, 3.25 GB RAM, NVIDIA GeForce GTS 250 512MB, Realtek HD Audio.


Mon Jul 09, 2012 12:40 am
Profile
User avatar


Joined: Sat Apr 03, 2010 5:16 am
Posts: 1078
Location: Roermond, the Netherlands
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Already reported. Reference.


Attachments:
WeirdBug.zip [1.14 KiB]
Downloaded 44 times

_________________
Do you have/need useful GeneRally tips & tricks?

Well...

The Great Track Tips & Tricks Topic
Mon Jul 09, 2012 12:08 pm
Profile
User avatar

GeneRally Carmaster

Joined: Sun Dec 27, 2009 3:06 pm
Posts: 300
Location: Finland
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Intended behaviour. Whilst many file format changes in GR are supported in later versions - old ghost laps aren't overtly supported in this fashion. We may consider introducing this in future, but it's unlikely. The reason this works between v1.05 and v1.10 is because the necessary internal format for drivers/players remained the same between those two versions.


Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
The ghost car shows up oddly in 1.2, if the record (hot)lap is driven in an older version:
When you start, the ghost car doesn't show up. When you begin your second lap,
it appears, the car is the one with which the real (hot)lap record is driven, but the lap it
drives is the one you just drove, not the real record lap.

Expected Behaviour
The ghost car should work normally and drive the real record lap on every lap.

Reproduction
Select a track in GR 1.2, for which the hot lap record is driven in GR 1.10 (or older).
Toggle the ghost car 'on' in the options menu.
Go drive a hotlap session on the track.
On the first lap, there won't be a ghost car, but it
appears when you begin your second lap.

System Configuration
Operating System: Windows XP Home Service Pack 3
Hardware: AMD Athlon X2 4800+ 2.8 GHz, ATI Radeon HD 2600 Pro 512 MB

_________________
My latest creation: F-Astor Junior

I know only that I do not know

Long live speed, thrash, death, black and doom metal without forgetting grindcore!


Mon Jul 09, 2012 12:30 pm
Profile E-mail
User avatar

GeneRally Carmaster

Joined: Sun Dec 27, 2009 10:59 am
Posts: 4125
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Rejected. First off, I can't reproduce this. Secondly, this isn't in any way governed by GR - it's entirely OS-based. There's quite simply nothing we can fix here.


Problem:
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? N/A
Track Editor cannot be assigned to .trk files.

Expected Behaviour:
I should be able to assign tracks to be opened by TE.

Reproduction:
Attempt to assign .trk files to trackeditor.exe. It won't work, or even load the program into the list of programs.

System Configuration
Operating System: Windows Vista Home Premium SP2
Hardware: Intel Core i3 2120 3.4 GHz, 2x2gb DDR3 RAM, NVidia GeForce 8600GTS 256MB PCI-E, 640GB+2x160GB HDDs (game on 640 GB HDD), ASUS Xonar DG

Quote:
With regards to my post above, I believe it may be that Windows cannot reassign a file format to a program that shares the same name as one that has been deleted, or something along those lines - I was able to assign it by renaming TE "trackedit.exe".


Mon Jul 09, 2012 4:13 pm
Profile

Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. Reproduced and fixed. We'll wait a few days/weeks to see if any other bugs crop up before releasing this. For now, restart GR after abandoning a timed race early :)

Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
Setting race in minutes + 2 laps mode gives you additional second to the time. E.g. I picked 2 minutes, and at the start of the race i have 2 min and 7 sec.

Expected Behaviour
Time should be counted from the proper value.

Reproduction
Start game
Go to settings
Pick in race lenght option minutes (+2 laps)
Go back
Start a race
You'll s**t bricks.

System Configuration
Operating System: Windows 7 SP1 x64
Hardware: Intel Core 2 Duo 2.2 GHz, 4GB RAM, NVIDIA GeForce G102M


Wed Jul 11, 2012 9:39 pm
User avatar


Joined: Tue Mar 22, 2011 10:23 am
Posts: 131
Location: Austria
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Already reported. Reference. Thanks for the additional information, we've fixed it.

I have the same problem like Areen. I started 10-minute-races on the same track several times and got these times:
10 00
11 35 (!)
10 28
10 09 (start race - see timer - abort race - restart race .... results in a few seconds overlap)
10 05
10 05
10 10
10 10
10 04
...
after some minutes
16 06 (!)
10 47
10 28 (start race - see timer - abort race - wait - restart race .... results in more seconds overlap)
...

I think that the time between race starts has something to do with that. Maybe the fact that I never finished a race plays a role here.

System Configuration
Operating System: Windows 7 SP1 x64
Hardware: Intel Core i7 2670QM, 2.2 GHz, 6GB RAM, AMD Radeon HD 7610M


Attachments:
shot0001.jpg
shot0001.jpg [ 303.31 KiB | Viewed 10386 times ]
Thu Jul 12, 2012 7:25 am
Profile E-mail
User avatar

GeneRally Carmaster

Joined: Sun Dec 27, 2009 10:59 am
Posts: 4125
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Intended behaviour. We're happy with the level of blood. This isn't going to be changed.

Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
Driving on people's heads, or even lightly touching them/driving against them but not at high-speed into them, does not result in any blood - it should be like the pitcrew, you've gone too far with removing the blood.

Expected behaviour
Contact with a person should have the same effects as hitting a member of the pitcrew (not necessarily moving them) or driving over a stand.

Reproduction
Drive into a group of people lightly, or over their heads on a specially set-up track. You'll see what I mean.

System Configuration
Operating System: Windows Vista Home Premium SP2
Hardware: Intel Core i3 2120 3.4 GHz, 2x2gb DDR3 RAM, NVidia GeForce 8600GTS 256MB PCI-E, 640GB+2x160GB HDDs (game on 640 GB HDD), ASUS Xonar DG


Thu Jul 12, 2012 7:32 pm
Profile
User avatar

GeneRally Carmaster

Joined: Sun Dec 27, 2009 3:06 pm
Posts: 300
Location: Finland
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Intended behaviour. This won't be changed.

Problem
Observed in v1.2b? Yes
Observed in v1.10c? No
Observed in v1.05? No
Hotlap times made by an AI driver don't show on the top times list.

Expected Behaviour
All hotlap times should show on the top times list, regardless of the driver type.

Reproduction
Choose a track with preferably no hotlap times recorded.
Put one AI driver to drive on the track, ie. a hotlap session.
When the results screen appears, there will be no times.
(The same happens if there are human-made times before the AI's hotlap session:
AI-made times won't show up in the list, even if the times should be there.)

System Configuration
Operating System: Windows XP Home SP3
Hardware: AMD Athlon X2 4800+ 2.8 GHz, ATi Radeon HD 2600 Pro 512 MB

_________________
My latest creation: F-Astor Junior

I know only that I do not know

Long live speed, thrash, death, black and doom metal without forgetting grindcore!


Fri Jul 13, 2012 10:13 pm
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Sun Jan 03, 2010 1:03 pm
Posts: 395
Location: Gosford, NSW, Australia
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Rejected. This won't be fixed in v1.2 (the behaviour is the same in v1.10 as well, no changes were made in this area) - but we'll try to ensure there's good multi-monitor support in the sequel.


Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? N/A
1. The game does not go to full screen on the monitor that the GR window is in if the game window has been moved to an alternative monitor to which GR was opened.
2. The window resolution size does not give the correct monitor options when the GR game window is dragged to a second monitor (or alternative monitor to which GR was opened)
EDIT: It appears that GR will only give the current resolutions for the primary monitor, not both, Irrespective of whether or not I get the game to open in the second monitor on start up. Both conditions above still apply. Even after opening the window on my secondary monitor, it only displays the primary monitor resolutions and will only apply full screen to the monitor it opened in, rather than the current monitor the game is on.

Expected Behaviour
The game should be able to detect all available resolutions to the PC available when presented more than one monitor on game startup and if required, provide full screen to the current monitor it is on.

Reproduction
Open GeneRally
(Place in Windowed Mode if not already)
Drag Window from one monitor to the next
Options/Advanced
Resolution list displays all resolutions native to the original monitor and not the current one

System Configuration
Operating System: Windows 7 Professional 32bit
Hardware: Intel Core 2 Duo 3 GHz, 2x2gb DDR2 RAM, ATi Radeon HD 3800 256Mb PCI-E, 160GB ATA HDD, HP vs17e Monitor (primary) + Acer AL1916W Monitor (secondary, larger resolutions available).

_________________
Latest Circuits - [cir] Faerie | [cir] Casedure
Latest Cars - [lmp] Aola Proto1 | [tou] Aola Coupé1
View my archived circuits/cars here
Skype: crowella90


Sat Jul 14, 2012 12:17 am
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Sat Dec 26, 2009 9:54 pm
Posts: 7083
Location: CZE
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. This no longer occurs in v1.2c.


Problem
Observed in v1.2? Yes
Observed in v1.10c? Yes
Observed in v1.05? No
Persons are not in right angle when standing on elevation change on randomly shaped not-water-like-flat hmap. It's wrong, not naturally looking. In result one of most common things related to racing, which can be on track - grass banks for fans - looks always weird, which hurts my eyes (but hurts them all the time of the race :ill: - not like already-fixed blood issue, which was occurring just when driving close to them, so this is more serious). :worried:

Expected Behaviour
Persons should stand like when persons stand in real on hill, in 90° to water level, not to actual hmap.

Reproduction

1. Go outside on a hill (can be just an uphill on road/street near your house, not necessary to do a mountain climb adventure), stop to stand next to nearest tree or traffic sign there. Observe. :)
2. Look at this picture, focus on persons, trees and traffic sign. It's wrong.
Attachment:
grass bank.png
grass bank.png [ 6.05 KiB | Viewed 10258 times ]

Attachment:
standing.png
standing.png [ 5.46 KiB | Viewed 10258 times ]

_________________

My GR Racing Stats; thanks to GWR!


Thu Jul 19, 2012 8:41 am
Profile E-mail WWW
User avatar


Joined: Mon Mar 15, 2010 11:30 am
Posts: 187
Location: Włocławek, Poland
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. This no longer occurs in v1.2c.


Problem
Observed in v1.2b? Yes
Observed in v1.10c? No
Observed in v1.05? No
TrackEditor doesn't name new trakcs with random names.

Expected Behaviour
TrackEditor should name new tracks with random names.

Reproduction
Start TrackEditor.

System Configuration
Operating System: Windows 7 64-bit
Hardware: Sony Vaio VPCF12M1E


Attachments:
File comment: TrackEditor - 1.10c
te110c.png
te110c.png [ 45.78 KiB | Viewed 10206 times ]
File comment: TrackEditor - 1.2b
te12b.png
te12b.png [ 44.37 KiB | Viewed 10206 times ]
Wed Jul 25, 2012 6:17 pm
Profile E-mail
User avatar

GeneRally Carmaster

Joined: Mon Mar 01, 2010 10:59 am
Posts: 203
Location: -----> <-----
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Rejected. Firstly, this isn't a game issue. Secondly, this is certainly a false-positive by your AV software (see below). The archives for all versions of GeneRally are scanned prior to upload and, just for sanity, I have just (i.e. in the last 30 seconds) re-scanned the uploaded archive locally and via avast!'s online file scanner - both turned up clean.

Furthermore, I tested using VirusTotal online (which scans files using 41 of the most popular AV solutions, with the most up-to-date virus definitions) and only TrendMicro turned up anything. There seem to be a good number of reports of false positives on PAK_GENERIC.001 from TrendMicro software in recent times - however, this is understandable considering that PAK_GENERIC.001 covers a vast number of different possible root causes (hence the 'GENERIC' part of the name). Given the results of all aforementioned tests, I can safely say to you that 39/41 of the leading anti-virus software applications on the market today mark GeneRally v1.2b as virus-free, clean and safe to download :) - with a ratio like that, it's safe to say that TrendMicro's result is a false-positive. The benefit of using heuristic threat detection is that it covers a vast scope and can account for subtle variations... the problem is that it can also create a lot of false-positives.


Virus warning when downloading the game file

Problem
Observed in v1.2? Yes
Observed in v1.10c? No but not sure
Observed in v1.05? No

When I start downloading the file my virus scanner (Trend Micro) shows an alarm that it found a threat called "PAK_GENERIC.001" in the file.

The explanation reads as follows

This is the detection for possibly malicious executable files that are compressed using Win32 compression tools. This proactive detection also includes appending viruses found in the wild.

It is a heuristic detection based on well-established characteristics inherent to compressed malware. To keep customers a step ahead from possible malware infections, all executable files found in the system that match established characteristics are immediately detected.

If your Trend Micro product detects a file under this detection name, do not execute the file. Delete it immediately especially if it came from an untrusted or an unknown source (e.g., a Web site of doubtful nature).

Expected Behaviour
Should not show a virus detection. I trust that you did run your virus scan on it.

Reproduction
Yes

System Configuration
Operating System: Windows 7

_________________
-------------------------------------------------------------------
Need more X tracks and cars? Check out
http://genetleman.jimdo.com and / or http://jolly.yoll.net

MBX6-T driver


Fri Jul 27, 2012 8:20 am
Profile WWW
User avatar


Joined: Mon Mar 15, 2010 11:30 am
Posts: 187
Location: Włocławek, Poland
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Rejected. After looking into this, we won't be changing this behaviour in v1.2c due to the amount of work required to support custom resolutions in a sensible fashion (we also really would like to avoid a v1.2d - so we're looking mainly at critical fixes).


Problem
Observed in v1.2? Yes
Observed in v1.10c? No
The game crashes at start (screenshot included). Problem occurs both in 1.2 and 1.2b.

Expected Behaviour
If GeneRally can't find supported resoultions, maybe it should allow to set any? (like in 1.10c)

Reproduction
Open the game.

System Configuration
Operating System: Windows Vista x86
Hardware: AMD Athlon(tm) 64 X2 Dual Core Processor 4800+ 2.5GHz; ATI Radeon HD2400; 2GB RAM; Monitor Philips 190Sw8

It's not on my computer, but I'm writing this bug report. I have a possibility to contact this person, so you can ask me.
This problem occurs with "clean" installation of GR 1.2(b).

@EDIT Installing the newest version of graphics card drivers helped - GR 1.2b now works.


Attachments:
File comment: Screenshot.
gr12.png
gr12.png [ 20.4 KiB | Viewed 10162 times ]
Fri Jul 27, 2012 11:04 am
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Tue Dec 29, 2009 6:37 pm
Posts: 4725
Location: NRW in Germany
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. This no longer occurs in v1.2c.


Problem
Observed in v1.2? Yes
Observed in v1.10c? N/A
Observed in v1.05? N/A
The game crashes when a moveable road cone hits a person. (only in certain cases)

Expected Behaviour
The game should not crash when a moveable cone hits a person.

Reproduction

1. Select track (I will send it to James, if anyone else wants to test it drop me a message within the next day)
2. Drive through the cones in that way that they will touch the persons
3. Crash

I attach an image to show the way I crash my game.

System Configuration
Operating System: Windows XP
Hardware: AMD Athlon 2200+, 768 MB RAM, NVidia Geforce 4 MX 4000 GT 64MB, 80GB HD, C-Media Wave


Attachments:
preview.png
preview.png [ 47.54 KiB | Viewed 10130 times ]

_________________
My e-mail-address:xyyverwaltung@googlemail.com
Last track: deRUkt89.-Z+ - Last car: Ford Falcon GTHO Phase III
Sun Jul 29, 2012 12:07 am
Profile
User avatar


Joined: Fri Nov 26, 2010 5:51 pm
Posts: 47
Location: Franca, SP, Brazil
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. This should be fixed in the current version.


Problem
Observed in v1.2? Yes
Observed in v1.10c? N/A
Observed in v1.05? N/A
The game volume editor don't make any change on the volume

Expected Behaviour
The volume must change according to the selected percentage

Reproduction

1. Make sure that you PC volume is on max.
2. Now go to GR advanced options and put a low percentage (i put 9%, 10%, 11% on the game order)
3. Run the game and hear... The sound is very high.



System Configuration
Operating System: Windows 7 x64
Hardware: 4 GB ram, 500 HD, Onboard videocard, intel i3.

_________________
"Para sempre Ayrton."

Track DataBase Don't forget to up your tracks there!!!


Wed Aug 08, 2012 4:01 am
Profile E-mail
User avatar


Joined: Tue Jun 29, 2010 4:07 pm
Posts: 232
Location: UK
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Fixed. This has been fixed, if we do a v1.2d, the fix will be in there.


Problem
Observed in v1.2c? Yes
Observed in v1.2b? Yes
Observed in v1.10c? No
Observed in v1.05? No

Timed races in a season after loading from autosave count-down from an incorrect time, differing from the time showed on the race brief.

Expected Behaviour
Timed races loaded should be the same as the time on the race brief.

Reproduction
set race type to minutes.
set a time (say 2 minutes).
select some tracks and drivers.
go race.
save season before start of any race, overwriting the autosave.
then load the same autosave.
popup at start will display correct time, but actual race time is different.

System Configuration
Operating System: Windows 7
Hardware: AMD Athlon II X2 Processor M300 (2.0GHz, 1MB L2 Cache), 3GB RAM, ATi Radeon HD 4200 Graphics

EDIT: Confirmed for v1.2c, added screenshots.


Attachments:
shot0002.png
shot0002.png [ 588.02 KiB | Viewed 10027 times ]
shot0001.png
shot0001.png [ 571.75 KiB | Viewed 10027 times ]
Sun Aug 12, 2012 5:41 pm
Profile
User avatar


Joined: Fri Nov 26, 2010 5:51 pm
Posts: 47
Location: Franca, SP, Brazil
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Under consideration. We'll look into it and decide whether it's worth releasing v1.2d for this or not :)


Problem
Observed in v1.2c? Yes
Observed in v1.2b? Yes
Observed in v1.10c? No
Observed in v1.05? No

While making a track, the zoom seems not to be right according to the value imput

Expected Behavior
Zoom should be proportional to the value.

Reproduction
Create a new track.
Put is on zoom 10
On generally, right-click on the track and see that the zoom is normal (very very close to the track)
Now, start a race on the track and see that the zoom isn't the same (it's like a far zoom, like 70, 80...)

System Configuration
Operating System: Windows 7 x64 (home basic)
Hardware: 4 GB ram, 500 HD, Onboard videocard, intel i3.

The track on the print is saved in zoom 10. Look the print of the track statistics. The zoom actually works (in this case there is no thumbnail because the zoom value is too small for the hmap). Now on race, see the zoom actually normal. Believe it or not, the zoom on this track is 10.


Attachments:
shot0001.jpg
shot0001.jpg [ 195.69 KiB | Viewed 9997 times ]
shot0000.png
shot0000.png [ 79.72 KiB | Viewed 9997 times ]

_________________
"Para sempre Ayrton."

Track DataBase Don't forget to up your tracks there!!!
Wed Aug 22, 2012 3:43 pm
Profile E-mail
User avatar

GeneRally Trackmaster

Joined: Tue Dec 29, 2009 6:37 pm
Posts: 4725
Location: NRW in Germany
Post Re: GeneRally v1.2 - BUG REPORTS
James wrote:
Rejected. As above, we won't be changing this behaviour due to the amount of work required to support custom resolutions in a sensible fashion (we also really would like to avoid a v1.2d - so we're looking mainly at critical fixes). As it is now, we use a system-level function to obtain resolutions reported by the graphics driver, so this is about as good as it gets.


Problem
Observed in v1.2? Yes
Observed in v1.10c? No
Observed in v1.05? No
Some of the screen resoultions which would work with my display aren't shown in the list

Expected Behaviour
All resolutions available (or at least all which can be shown by my screen) should be in the list, not only a selection

Reproduction

1. go to the options menu
2. click onto the selected resolution
3. There are only available following resolutions: 640*480, 800*600, 1024*768, 1152*864, 1280*1024, 1440*900, 1600*900, 1680*1050
My suggestion: not limit the available resolutions by what GR detects, but allow everything. Then you could make an alert/warning if a user selects a resolution which is not detected. Because this way (a) all resolutions will be shown (b) I can still make super-big preview images in 2560*1920 windowed mode and scale them to have an antialiasing-similar effect on screens (c) someone unexperienced won't change to a resolution not allowed by his screen. And even if he selects it and the game crashes, at the next start of GR will be the old resolution :D


System Configuration
Operating System: Windows XP
Hardware: Intel Core 2 Duo 3.0 GHz, 4gb RAM, Nvidia GeForce 9800GT, 1680*1050 display, 500GB HDD.

_________________
My e-mail-address:xyyverwaltung@googlemail.com
Last track: deRUkt89.-Z+ - Last car: Ford Falcon GTHO Phase III


Tue Sep 04, 2012 12:36 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 40 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.